Hi Friends,

My sole purpose to start this forum is to unite all TUV 300 owners to share their experience no matter good or bad, to benefit others and bring niggles till Mahindra officials.

Please share your thoughts and publicize this forum to make our voice stand tall.

Thanks,
VP

TUV 300 T10 AMT

Latest updates and announcements regarding forum.
manoj69kr
Newbie TUVian
Posts: 1
Joined: 16 Feb 2018, 16:32
Location: New Delhi
Status: Offline

TUV 300 T10 AMT

Postby manoj69kr » 16 Feb 2018, 16:39

Dear Friends

I have bought TUV300 T10 AMT model in Oct17. There are some issues I have noticed

1. Video Playback is not happening while vehicle moving
2. Truck Like sound coming but not so frequent
3. Suspension is not good facing lot of issues while driving in rough patches.

I have run the vehicle almost 9000 km till today i.e. 16th Feb 2018.

Please if any one have any the same vehicle can share their reviews or help in getting the issue address.

Also would like to know that which service centre is best of Mahindra. GSP Mahindra at Gurgaon Sec-35 is not appropriately handle the vehicle issues. Please share your experiences.

Thanks
Manoj Kumar

makolawala
Newbie TUVian
Posts: 1
Joined: 13 Mar 2018, 20:03
Location: Thane(W)
TUV 300 Varient: T8 AMT
Status: Offline

Re: TUV 300 T10 AMT

Postby makolawala » 13 Mar 2018, 20:12

Small issues with Mahindra is always no problem as they are very consistent with it.
I Had problems with my T10 AMT, that i had to raise it to 2000 rpm to mobilize the the tank in either gear F & R.
@2000 rpm vehical runs at 80kmph.

Very 2nd day i took my tank to service station some software patching and issue resolved.
After 3000 km s done, i have another issue, manual transmission indicator lits ON randomly.
Vehicle stalls when this indicator comes on.

Any one facing the same problem can guide me.


Return to “Latest Updates & Announcements”

Who is online

Users browsing this forum: No registered users and 0 guests