Page 1 of 1

Hello to everyone

Posted: 27 Jan 2017, 20:28
by Pratap
I'm Pratap.S.Tomer from Visakhapatnam, Bought fully loaded TUV300 AMT last year in February, just clocked 30K and took for service. Like everyone who bought the same variant I am also facing similar problems with my vehicle. Moreover I'm now getting new problem there's a huge gear disengage noise when moving from neutral/N to 1st gear/A1 or when slowing down and again pushing the acceleration from A1 and this is happening in both Automatic and Manual mode, vehicle does not move and the noise of gears disengagement is so loud that sometime I fear that the whole engine will come apart...trust me. On second attempt it works fine for which you need to again go back to N and then A1.
This new problem started immediately after I took the vehicle back after 30K service, for service I paid close to Rs7K. Vehicle is given back to Mahindra dealer service center (M/s.Automotive Manufacturer Pvt.Ltd at Maddlipalem) on 25th Jan'17 and they are still working on it.
I haven't got a replacement vehicle yet. I'll wait and watch and if the result is not satisfactory enough trust me guy's I'll sue Mahindra for millions of dollars for putting my life to risk.

Re: Hello to everyone

Posted: 10 Feb 2017, 16:11
by Pratap
Guy's my vehicle still at dealers service station and they are going crazy with it's repair in gearbox since Jan 25th' 20017...some parts which were sent by manufacturer mahindra does not match....that's shocking. ..very scary. I'm still using their Bolero and will ask to replace bolero with XUV500

Re: Hello to everyone

Posted: 05 Aug 2017, 21:29
by ravikiran53746
Pratap

Wats happening is your tuv alright now


Sent from my iPhone using Tapatalk