Hi Friends,

My sole purpose to start this forum is to unite all TUV 300 owners to share their experience no matter good or bad, to benefit others and bring niggles till Mahindra officials.

Please share your thoughts and publicize this forum to make our voice stand tall.

Thanks,
VP

Gear shifting to neutral(AMT) while driving!

Mileage, NVH, Batteries, Tyres and anything thats TECHNICAL!
abeymech
Newbie TUVian
Posts: 7
Joined: 26 Jul 2016, 10:58
Status: Offline

Gear shifting to neutral(AMT) while driving!

Postby abeymech » 06 May 2017, 11:21

Hi guys,
Last week had taken a trip to munnar with my family.
Reached safely but later while trying to take the vehicle up a steep climb, an issue popped up wherein the gear started slipping to neutral by its own and once slipped, it's stuck in neutral.
This happens both in forward and reverse.
The only option is to off the vehicle and restart to take it back to forward gear.
Somehow managed to bring the vehicle back to cochin and the same day visited the service Centre(on 29th april).
The advisor told me it's a hydraulic oil leakage from some component above the amt unit and the part has to be ordered from mahindra.
It's been over a week and still no update from the service Centre or Mahindra.
Just now I put in a complaint with their customer care and was assured a call back regarding the same from the area manager..
Had issues with sudden jerking while accelerating after slowing down in traffic or humps.but when the service guys drive they don't feel anything... Very strange!.. Hoping this issue will get solved once that particular part is changed...
Thirdly issue with wheel spinning.. Haven't told them seriously about this...
But after reading certain threads wherein they have a solution to this in the form an improved suspension system, I'm putting this complaint too...
Hoping my tuv will give a better ride after it comes out from the service Centre..

Guys.. If anyone have experienced the above situation and had it resolved please do respond...

Thanks

Sent from my ONEPLUS A3003 using Tapatalk

Return to “Technical”

Who is online

Users browsing this forum: No registered users and 1 guest