Hi Friends,

My sole purpose to start this forum is to unite all TUV 300 owners to share their experience no matter good or bad, to benefit others and bring niggles till Mahindra officials.

Please share your thoughts and publicize this forum to make our voice stand tall.

Thanks,
VP

Lost pick up in B2B traffic

Mahindra TUV 300 General Discussion
Ashwin
Newbie TUVian
Posts: 6
Joined: 11 Oct 2016, 11:18
TUV 300 Varient: T8
Status: Offline

Lost pick up in B2B traffic

Postby Ashwin » 11 Aug 2017, 18:13

Hello All,

Twice in past two weeks i have noticed a weird problem with T8, Manual.
if say for 30 minutes or an hour , we drag in bumper to bumper traffic, it seems engine has no power, Even at maximum throttle/accelerator vehicle do not move. This started two weeks back , Today is 11 Aug. My car is about 10 months young :) .

Has anyone noticed the same ever? Note- in Manual version not AMT.
I have a plan to call Mahindra center but thought of checking in the group if any one else has ever noticed this before & how it got fixed.

any advise is appreciated.

Thx in advance.

Regards
Ashwin

jayakarthik2008
Newbie TUVian
Posts: 23
Joined: 08 Jul 2016, 21:57
Location: Chennai
TUV 300 Varient: T8
Status: Offline

Re: Lost pick up in B2B traffic

Postby jayakarthik2008 » 11 Aug 2017, 22:27

Hi Ashwin,

Had this kind of problem twice, during long drives say more than 100Kms.. The problem was one of the Hose from Radiator (Driver side of the engine compartment) got loosened and disconnected which led to loss of acceleration and heavy black smoke.. just adjusted the hose and re-tightened the hose clip and it solved the problem at first instance.. The same problem occurred around 100Kms drive again.. Then found that there's a small flat ring like attachment inside the clip provided for extra support which is very smooth and made it slippery..

Replaced the clip with an aftermarket one and no problems there after..

In your case, if it resolved itself then it may be some other issue.. pls confirm with service centre..

harikrishnan
Newbie TUVian
Posts: 70
Joined: 01 Jun 2016, 19:28
Location: coimbatore
TUV 300 Varient: T8
Status: Offline

Re: Lost pick up in B2B traffic

Postby harikrishnan » 15 Aug 2017, 13:50

Share the parts location

Sent from my Lenovo P1a42 using Tapatalk

Ashwin
Newbie TUVian
Posts: 6
Joined: 11 Oct 2016, 11:18
TUV 300 Varient: T8
Status: Offline

Re: Lost pick up in B2B traffic

Postby Ashwin » 16 Aug 2017, 13:54

Thx Hari . Noted . Got a call from Mahindra care centre and soon they will arrange a real time drive test in B2B traffic . To identify the issue. I hope we will be able to reproduce the error but as I told Mahindra not sure if we can . Will reply all after the test results .

Yeah it seems an intermittent issue and on top of that gets corrected on its own , as you suggested May be the cause is different .

Thx again . Will reply after the test drive results

harikrishnan
Newbie TUVian
Posts: 70
Joined: 01 Jun 2016, 19:28
Location: coimbatore
TUV 300 Varient: T8
Status: Offline

Re: Lost pick up in B2B traffic

Postby harikrishnan » 17 Aug 2017, 16:39

Leave the car at dealer ship.demand for free bees

Sent from my Lenovo P1a42 using Tapatalk

jarnailsingh
Newbie TUVian
Posts: 41
Joined: 14 Jun 2016, 22:33
Location: ferozepur punjab
TUV 300 Varient: T8
Status: Offline

Re: Lost pick up in B2B traffic

Postby jarnailsingh » 23 Aug 2017, 19:19

Ashwin wrote:Hello All,

Twice in past two weeks i have noticed a weird problem with T8, Manual.
if say for 30 minutes or an hour , we drag in bumper to bumper traffic, it seems engine has no power, Even at maximum throttle/accelerator vehicle do not move. This started two weeks back , Today is 11 Aug. My car is about 10 months young :) .

Has anyone noticed the same ever? Note- in Manual version not AMT.
I have a plan to call Mahindra center but thought of checking in the group if any one else has ever noticed this before & how it got fixed.

any advise is appreciated.

Thx in advance.

Regards
Ashwin



hello bro. sorry to here that.. will u plz tell me.how much km u have drive ur vehicle..

Ashwin
Newbie TUVian
Posts: 6
Joined: 11 Oct 2016, 11:18
TUV 300 Varient: T8
Status: Offline

Re: Lost pick up in B2B traffic

Postby Ashwin » 26 Aug 2017, 09:24

Hello jernail Ji,
approx 14000 KM

Hi All,
Update-

i went to Mahindra's service station- Vaccum Modulator EGR was replaced ( Free of cost). Now this is my understanding - Though i have no supporting document to prove- Mahindra Knows about the problematic device & they might be doing a research to get the root cause why This particular device is going bad. I believe the number of reported problems due to this device are less.

Service center guys have replaced OIL PRESSURE SWITCH as well. I was told this is not related to problem is my vehicle but Mahindra is doing it for Most of the TUVs ( no Vehicle recall that i am aware off) . being a Layman I took it as - a component they might have identified - to be replaced along with Vaccum Modulator EGR. I dont know.

Ty all. when you visit for a vehicle service - try to get more input on this.

Prompt response from Mahindra people is APPRECIATED.

Thanks for the portal owner to allow us to share our experience (s) which can be beneficial for others.

Cheers.

Ashwin

Ashwin
Newbie TUVian
Posts: 6
Joined: 11 Oct 2016, 11:18
TUV 300 Varient: T8
Status: Offline

Re: Lost pick up in B2B traffic

Postby Ashwin » 26 Aug 2017, 09:25

Typo- "I was told this is not related to problem IN my vehicle"


Return to “General Discussion”

Who is online

Users browsing this forum: No registered users and 1 guest